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Unit Brief: Showcase the Venture Project 
 
UNIT PROJECT: Present the Venture Project 
 
BACKGROUND: When development of a project is complete, it is usually necessary to 
present the finished product to prospective customers, team members, and others. The best 
way to do this is to create informative slides that present the project information in an 
orderly, logical, and creative manner.  
 
In this unit, YTE students have the opportunity to enhance their public-speaking skills, as 
well as learn how to create a multi-slide presentation in Microsoft PowerPoint — the 
presentation software program of choice in countless offices around the country and the 
world.     
 
CHALLENGES: Present to an audience; provide feedback; use PowerPoint to create slide 
presentations. 
 
DELIVERABLE: Presentation on the Venture Project 
 
MILESTONE ACTIVITIES 
To complete this unit successfully: 

• Estimate the project value 
• Develop skills in PowerPoint 
• Give Venture presentations 
• Complete the unit assessments  
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Unit Assessment Summary 
 
Throughout the unit, you will complete and be graded on the following: 
 
PROJECT - ____ % 

• YTE Skills Assessment 
• Venture Project Presentation 

 
QUIZZES/TEST - ____ % 

• Skills Assessment 
• Vocabulary Assessment 
• Knowledge Assessment 

 
ENRICHMENT ACTIVITIES - ____ % 

• Compare the Project’s Value in Different Parts of the Country 
• Create a PowerPoint Presentation About Yourself 
• Present the Venture Projects to Other Groups   
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Unit Scope of Work 
 
TASK LIST 
To complete the unit, the class will engage in the following tasks: 
 
1.  Review project and skills 

• Review the project brief 
• Complete the Unit Skills-Self-Assessment 

 
2.  Develop team skills 

• Communication/interpersonal skills 
• Leadership skills 
• Presentation skills 
• Evaluation and feedback skills 
• Assessment skills 

 
3.  Estimate the project value 

• Estimate the value of the Venture Project 
• Research and report on the value of the Venture Project 

 
4.  Develop skills in PowerPoint 

• Introduce Microsoft Powerpoint 
• Demonstrate PowerPoint 
• Plan the PowerPoint presentation 
• Create an outline 
• Collect the content 
• Create the PowerPoint presentation 

 
5.  Give Venture presentations 

• Brainstorm components of an effective presentation 
• Plan the presentation 
• Discuss constructive feedback 
• Give constructive feedback 
• Complete a self-evaluation  

 
6.  Complete the unit assessments 

• Skills Assessment 
• Vocabulary Assessment 
• Knowledge Assessment 
• Unit Skills Self-Assessment 
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Lesson Planner 
 
Unit objective: Present the Venture Project 

Suggested total class 

sessions: 

11 (One class session equals approximately 50 minutes of actual time) 

 

  
 

Lesson 
 

Suggested 
sessions Lesson Objectives 

1 

 

1 Estimate the Project Value   

• Research salary information 

• Calculate the value of the Venture Project 

2 4 Develop Skills in PowerPoint 

• Create an outline for a slide presentation 

• Develop basic PowerPoint skills 

• Create a PowerPoint presentation 

3 

 

4 Give Venture Presentations 

• Identify the components of an effective presentation 

• Plan, rehearse, and give an oral presentation 

• Give constructive feedback 

• Assess your presentation and performance 

4 2 Complete the Unit Assessments 

• Skills Assessment 

• Vocabulary Assessment 

• Knowledge Assessment  

• Unit Skills Self-Assessment 

 



6 - 6 
 

© 2003 YTE All Rights Reserved 
 

 
WEB VENTURES 1 

Unit 6: Showcase the Venture Project 
YTE Skills Assessment 

 

 
 

 
 

 

YTE Skills Assessment 
Name:  __________________________________  Date:  __________ Class:  __________ 
 

 Minimal (1) Basic (2) Competent (3) Advanced (4) 
1.  Takes Initiative 

 Passive. Learning to 
take initiative on 
projects. 

 Sometimes takes 
initiative on projects. 

 Consistently takes 
initiative on various 
projects. 

 Volunteers for new 
projects and 
opportunities. 

2.  Behaves Professionally 
 Learning to be 

focused, punctual, and 
professional.  

 Sometimes focused, 
punctual, professional.  

  Consistently focused, 
punctual, professional. 

 Raises the 
professional level of the 
class/team. 

3.  Collaborates with Teammates 
 Learning to work 

well with other team 
members. 

 Sometimes works well 
with other team 
members. 

 Consistently supports 
other members, while 
working through issues. 

 Always contributes in 
moving team towards 
stated goal.  

4.  Persuades Others 

L
E
A

D
E
R

S
H

IP
 

 Learning how to 
ensure her/his points 
are heard.  

 Sometimes moves the 
group through 
persuasive conversation. 

 Consistently is looked 
to for direction by the 
group. 

 Provides direction for 
the group, while 
incorporating others’ 
ideas. 

1.  Plans Effectively  
 Learning to create a 

realistic and organized 
plan.  

 Plan is sometimes 
realistic and organized.  

 Plan is realistic and 
organized.  

 Plan can be flexible 
and adjusts for 
contingency scenarios. 

2.  Applies Technical/Business Skills Appropriately 
 Learning to select 

and use the proper 
skills correctly. 

 Sometimes selects 
and uses proper skills 
correctly. 

 Consistently uses and 
selects proper skills 
correctly.  

 Develops new skill(s) 
not required in 
assignment. 

3.  Develops Creative Ideas and Approaches 
 Develops few or no 

creative ideas and 
solutions. 

 Develops some new 
ideas and solutions. 

 Develops many 
creative ideas and 
solutions. 

 Sets creative standard 
for the class.  

4.  Executes Solution P
R

O
B

L
E
M

 S
O

L
V

IN
G

 

 Assignment of poor 
quality. Doesn’t check 
work. 

 Assignment of fair 
quality. At times checks 
work.  

 Project has few, if 
any, errors. Checks 
work. 

 Product shows obvious 
extra effort. 

1.  Demonstrates Understanding of Technical/Business Content 
 Written/verbal 

knowledge is not 
accurate or complete. 

 Written/verbal 
knowledge is sometimes 
accurate, nearly 
complete. 

 Communication 
demonstrates mastery of 
knowledge. 

 Through effective 
written and verbal 
communication, helps 
others understand 
subject matter.  

2.  Possesses Clarity in Written Communication 
 Main message 

unclear; information 
not organized. 

 Message is somewhat 
clear; somewhat 
organized. 

 Main message is clear 
and organized. 

 Very clear and easy to 
understand. 

3.  Provides Audience-Appropriate Presentation Content  
 Information not 

usually appropriate to 
audience.  

 Information somewhat 
audience-appropriate. 

 Information 
appropriate to audience. 

 Information highly 
appropriate to audience. 

4.  Presents Effectively 

C
O

M
M

U
N

IC
A

T
IO

N
 

 Distracting; hard to 
follow, unprofessional. 

 Somewhat easy to 
follow, prepared, 
professional. 

 Well-prepared, easy 
to follow, professional. 

 Presentation highly 
polished and engaging. 

See Comments on back. 
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YTE Skills Assessment 
 

Name:  __________________________________  Date:  ____________  Class:  _______ 
 
COMMENTS 

L
E
A

D
E
R

S
H

IP
 

 

P
R

O
B

L
E
M

 S
O

L
V

IN
G

 

 

C
O

M
M

U
N

IC
A

T
IO

N
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Unit Skills Self-Assessment 
 
Name:  ________________________________  Date:  _____________  Class:  ________ 
 
This table is a summary of the content taught in this unit. You will complete this worksheet 
once at the beginning of the unit and then again at the end of the unit. Check the column 
that best describes your level of understanding for each skill listed. 
 

 Minimal Basic Competent Advanced 

Academic/Leadership Understandings 
• Research salary information      
• Create an outline for a presentation     
• Assessment and evaluation skills     
• Perform metrics evaluation     
• Oral presentation skills     
• Active listening skills     
Business Understandings 
• Calculate the value of the Venture Project     
• Learn basic PowerPoint skills     
• Create a basic presentation     
• Give constructive feedback     
• Assess personal performance      
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Unit Resource Reference List 
 
The following is a list of all external resources that are referenced throughout the unit. 
 
Youth Tech Entrepreneurs, YTE Links Library: www.yte.org.links:  

• www.yte.org/links/Careers-Jobs/Job Search: Top Entry-Level Employers 
• www.yte.org/links/Careers-Jobs/Job Search/Monster 
• www.yte.org/links/Careers-Jobs/Job Search/Career Builder 
• www.yte.org/links/Careers-Jobs/Job Search/Tech Jobs 
• www.yte.org/links/Careers-Jobs/Job Search/Public Library Job Search 
• www.yte.org/links/Careers-Jobs/Job Search/Top 10 Employment-Related Sites 

 
Other sites of interest: 

• Consortium for Entrepreneurship Education: http://www.entre-ed.org/     
• Ewing Marion Kaufman Foundation Children & Youth Entrepreneurship Programs: 

http://www.emkf.org/pages/129.cfm  
• My Own Business: http://www.myownbusiness.org/  
• High School Startups.com: http://www.highschoolstartups.com/  
• Junior Achievement Student Entrepreneur Center: 

http://www.ja.org/studentcenter/entrp/default.shtml#  
• Teen Startups.com (part of Entrepreneur.com): http://www.entrepreneur.com/tsu  
• The National Foundation For Teaching Entrepreneurship: http://www.nfte.com/  
• Y & E: The Magazine for Teen Entrepreneurs: http://ye.entreworld.org/  
• YoungBiz: http://www.youngbiz.com/  
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Curriculum Alignment 
 

Lesson Frameworks Strands Standards 
Lesson 1:  Estimate 
the Project Value 

English Language Arts Language 
Composition 

4.26 
20.5, 24.5 

 Comprehensive Health 12: Consumer Health and 
Resource Management 

12.14, 12.20 

 History and Social Science Economics 
 

E.1.2, E.1.4, E.2.1, E.2.5, E.3.7, 
E.3.8, E.3.9, E.3.10 
 

Lesson 2: Develop 
Skills in PowerPoint 

English Language Arts Language 
Composition 
 
 
Media 

2.5, 2.6, 4.26 
19.26, 20.5, 20.6, 21.8, 22.10, 
23.13, 23.14 
27.6 

 Comprehensive Health 12: Consumer Health and 
Resource Management 

12.14, 12.20 

 History and Social Science Economics 
 

E.3.8, E.3.10  
 

Lesson 3: Give 
Venture 
Presentations  

English Language Arts Language 
 
Composition 
Media 

2.5, 2.6, 3.14, 3.17, 4.26  
20.5, 20.6, 25.5, 25.6 
26.5, 26.6, 27.6 

 Comprehensive Health 12: Consumer Health and 
Resource Management 

12.14, 12.20 

 History and Social Science Economics E.3.8, E.3.10 
 

Lesson 4: Unit 
Assessments 

English Language Arts Language 
Composition 
 
Media 

4.26 
20.5, 22.10, 23.13, 23.14, 25.6 
27.6 

 Comprehensive Health 12: Consumer Health and 
Resource Management 

12.14, 12.20 

 History and Social Science Economics E.2.1, E.2.4, E.3.8, E.3.9, 
E.3.10 
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 Lesson 1 

Estimate the Project Value 
 

Unit objective 

Present the Venture Project: 
• Estimate the value of the Venture Project 
• Develop basic PowerPoint skills 
• Create a PowerPoint presentation 
• Prepare, rehearse, and give an oral presentation with slides 
• Evaluate a presentation 

Academic 
objectives 

• Research salary information 

IT objectives • None 

Business 
objectives 

• Calculate the value of the Venture Project 

Suggested class 
sessions 

1  

Materials None 

Handouts Value of Services 

Web links 

www.yte.org/links/Careers-Jobs/Job Search/Top Entry-Level Employers 
www.yte.org/links/Careers-Jobs/Job Search/Monster   
www.yte.org/links/Careers-Jobs/Job Search/Career Builder 
www.yte.org/links/Careers-Jobs/Job Search/Tech Jobs 
www.yte.org/links/Careers-Jobs/Job Search/Public Library Job Search  
www.yte.org/links/Careers-Jobs/Job Search/Top 10 Employment-Related Sites   

Types of activities 
Documentation 
Research 
Writing 

Homework None 

Enrichment 
activity 

Compare the Project’s Value in Different Parts of the Country 

INTRODUCTION 
In this lesson, students will estimate the value of the services they provided during their 
Venture Project. Knowing the potential value of their entrepreneurial and technical skills is 
an added incentive to pursue technical and business management studies when they 
graduate from high school. 
 
Specifically, students will: 

• Research salary information 
• Calculate the value of the Venture Project 

WORD OF THE DAY 
• Market value. To know how much your services are worth on the open job market 

is powerful information. Students who have technical skills to offer an employer can 
negotiate for a much higher salary than those students who enter the job market 
with few or no skills. This can add significantly to a student’s confidence and self-
assuredness.  
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TEACHER PREP 
• Bring in the Help Wanted section from one or more Sunday newspapers. 
• Make copies of each team’s Weekly Status Reports. 
• Write the following phrases on the board: 

o Web Developer 
o Web Designer 
o Programmer 
o Information Technology 

Lesson Glossary 
• Gross pay. The amount of money you earn each pay period before taxes are 

subtracted. 
• Market value. The value of a product/service on the open market; the salary an 

employee can expect depending on his/her qualifications. 
• Net pay. The amount of money you earn each pay period after taxes are subtracted. 
• Supply and demand. When supply is great and demand is low, prices are low; 

when supply is low and demand is great, prices are high.  

STEP 1: Estimate the Value of the Venture Project  
Students receive several types of rewards for their efforts on the Venture Project: 

• Learning team skills 
• Learning technical skills 
• Learning entrepreneurial skills 
• Working with an outside client who will provide feedback, as well as a non-monetary 

token of appreciation.  
 
If your students were entrepreneurs and technical professionals working in the business 
world, they would gain a financial reward for their work on a project, which would be based 
primarily on the value of their labor. 

Activity: Research and Report on the Value of the Venture Project 
Divide your students into their Venture Project teams. Give each team copies of their 
Weekly Status Reports. Each team should calculate the total number of hours spent 
performing the tasks involved in its Project. For the purposes of this lesson, the students 
should count all the hours spent on “Weekly Accomplishments.”  
 
The students should then research the current salary or hourly rate for entry-level technical 
services personnel. They should look in the “Help Wanted” section of one or more local 
newspapers, and search the Internet for this information. 
 
The YTE Web site includes links to sites the students can use as references:  

• www.yte.org/links/Careers-Jobs/Job Search/Top Entry-Level Employers 
• www.yte.org/links/Careers-Jobs/Job Search/Monster   
• www.yte.org/links/Careers-Jobs/Job Search/Career Builder 
• www.yte.org/links/Careers-Jobs/Job Search/Tech Jobs 
• www.yte.org/links/Careers-Jobs/Job Search/Hot Jobs 
• www.yte.org/links/Careers-Jobs/Job Search/Public Library Job Search  
• www.yte.org/links/Careers-Jobs/Job Search/Top 10 Employment-Related Sites   
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As of this writing, www.yte.org/links/Careers-Jobs/Job Search/Monster allows you to run a 
personal salary report. 
 
Once the students have determined an average entry-level salary or an hourly rate for the 
type of work they performed on the Venture Project, they should complete the “Value of 
Services” handout. They should document the sources of their information.  
 
Remind the students that a typical full-time salary is the equivalent of 40 hours/week for 50 
weeks a year (assuming two weeks vacation), which equals 2000 hours/year. To compare 
the value of their work to a salary, they should use the following equation to determine the 
hourly rate: 

Salary / 2000 = Hourly rate 

ENRICHMENT ACTIVITY: Compare the Project’s Value in 
Different Parts of the Country 
Ask your students to perform the same research, but this time they should identify the 
typical rate of pay for the type of work they performed in three different areas of the 
country. For example, the students might find and compare the entry-level salaries for a 
Web Designer in Illinois, Kentucky, and Florida. 
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Value of Services 
 
Team Name:  ______________________________ Date:  ________  Class:  _________ 
 
List each source you consulted and the title of the job. Enter the hourly rate. If the source 
lists an annual salary, use this equation to determine the hourly rate: 

Salary / 2000 = Hourly rate 
Example: $36,000 / 2000 = $18 per hour 

 
Under Person Hours, enter the total number of hours all members of the team worked on 
the Project (based on your Weekly Status Reports). Multiply the Hourly Rate by the number 
of Person Hours to arrive at the Project Value: 

Hourly pay * Total Person Hours = Project Value 
Example: $18 * 154 = $2772 

 

Source Job Title Hourly Rate 
Total Person 

Hours 
Project Value 

www.monster.com Tech Services Rep $18 154 $2772 

     

     

     

     

     

     

     

 
Find the average Project Value: 

Total of all Project Value entries / # of Project Value entries 
 
The average value of a Venture Project is $____________________ . 
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Lesson 2 

Develop Skills in PowerPoint 
 

Unit objective 

Present the Venture Project: 
• Estimate the value of the Venture Project 
• Develop basic PowerPoint skills 
• Create a PowerPoint presentation 
• Prepare, rehearse, and give an oral presentation with slides 
• Evaluate a presentation 

Academic 
objectives 

• Create an outline for a slide presentation 

IT objectives • None 

Business 
objectives 

• Develop basic PowerPoint skills 
• Create a PowerPoint presentation 

Suggested class 
sessions 

4  

Materials None 

Handouts 
Basic PowerPoint Skills 
Presentation Requirements and Tips 
Slide Presentation Evaluation 

Web links None 

Types of activities 

Demonstration 
Team meeting 
Writing 
Hands-on 

Homework None 

Enrichment 
activity 

Create a PowerPoint Presentation About Yourself 

INTRODUCTION 
In this lesson, students learn basic skills in Microsoft PowerPoint — an essential tool for 
developing visual presentations. 
 
Specifically, students will: 

• Develop basic PowerPoint skills 
• Create an outline for a slide presentation 
• Create a PowerPoint presentation 

WORDS OF THE DAY 
• Layout. In an effort to make all of your slides appear the same (have the same look 

and feel) PowerPoint users should create and apply layouts that support the theme of 
their presentations. PowerPoint includes many preset layouts that any user can apply 
with little or no modification.  

• PowerPoint. This Microsoft Office application is the de facto standard for creating 
slide presentations in the business world. Knowing how to use PowerPoint is a very 
useful skill for virtually anyone in business; it’s not just for administrative personnel 
any more.  
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• Slide master. When you want to apply the same look and feel to a large number of 
slides in your presentation (or all of them) you can develop a slide master that 
automatically applies the page layout, font size, font color, logo, and any other 
design elements that you choose. Slide masters make it quick and easy to modify a 
large number of pages: make the change to the master and it is applied to every 
page that is based on it.  

• Template. A template provides preset information and blank fields where the user 
can insert his unique information. You can find templates in Microsoft Word; you can 
select from a number of templates that provide proper spacing and placement for a 
business letter, a professional resume, a friendly letter, and many more documents.  

TEACHER PREP 
Check whether you can access the PowerPoint 2000 tutorial from the classroom computers. 
If so, give the students some time to complete the tutorial during the first class session in 
this lesson. 
 
If you have taught this YTE course in the past, consider showing the class one or more 
student PowerPoint presentations from previous Venture Projects. 

Lesson Glossary 
• Layout. The arrangement, placement, or design of elements on a page or document.  
• PowerPoint. The presentation software included in Microsoft Office, used to create 

slides. 
• Slide master. The PowerPoint slide that dictates how all the slides based upon it will 

appear; changes in the slide master are applied to all slides based upon it.  
• Template. A pattern that serves as a guide. 

STEP 1: Introduce Microsoft PowerPoint  
In this step, you show students the basic steps involved in creating a PowerPoint 
presentation. If possible, use the PC projector to demonstrate the product. Otherwise, the 
students can follow along while you guide them through the steps. 

Activity: Demonstrate PowerPoint  
Follow the steps below to demonstrate PowerPoint from the PC projector: 

1. Open PowerPoint. 
2. Add a title to the opening slide of the presentation. 
3. Preview and select a design template (Format>Apply Design Template). 
4. Add a slide. 
5. Select a layout with bulleted text (Format>Slide Layout). 
6. Add a title and text to the slide. 
7. Add another slide. 
8. Select a layout that features an image. 
9. Add a piece of clip art to the slide (Insert>Picture>Clip Art). 
10. Add a slide and select another layout that features an image. 
11. Copy an image from another application or the Web and paste it into the slide. 
12. Add a slide and select another layout that features an image. 
13. Insert an image file from your computer into the slide (Insert>Picture>From File). 
14. Add a slide and select the layout that features a table. 
15. Create a simple table. 
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16. Add a slide and select the layout that features a chart. 
17. Create a chart. 
18. Display the presentation in Slide Sorter view (View>Slide Sorter). 
19. Move the slides around in Slide Sorter view. 
20. Display the presentation in Notes Page view (View>Notes Page). 
21. Add some text to the notes area. 
22. Display the presentation in Slide Show view (View>Slide Show). 
23. Display the slide master (View>Master>Slide Master). 
24. Change the default font used for the slide title. 
25. Redisplay the presentation in Normal view (View>Normal). Point out the change in 

font. 
26. Create a slide that uses the layout with just a title. 
27. Draw two shapes and add a text box to the slide. 
28. Point out the built-in animation features (Slide Show>Preset Animation). 
29. Apply an animation feature to one of the shapes on the slide. 
30. Display the presentation in Slide Show view (View>Slide Show). 
31. Open the online Help (Help>Microsoft PowerPoint Help). 
32. Look up a topic in the Help index (for example, “slide master”). 
33. Show how you can find the same information by entering a query on the Answer 

Wizard tab (for example, “How do I edit a slide master”). 
 
Distribute copies of the “Basic PowerPoint Skills” handout to the students. 

STEP 2: Plan the PowerPoint Presentation 
Explain that your students will present their Venture Project to the class during the next 
lesson. One part of each presentation will be a PowerPoint show that consists of 10 to 15 
slides. 

Activity: Create an Outline 
The students should meet in their Venture Project teams. For ten minutes, the teams should 
brainstorm the information they want to include in their PowerPoint presentations.  
The students should then select the ideas they like best and put them in the proper order 
for the presentation. 

Activity: Collect and/or Create the Content 
The team must decide who will perform the tasks involved in creating the presentation. 
These tasks include: 

• Writing the text for the presentation 
• Collecting or creating images 
• Creating the presentation in PowerPoint 

 
Based on their roles, the students should then: 

• Draft the text 
• Create and/or gather images 
• Further explore PowerPoint features 

 
Distribute the “Presentation Requirements and Tips” and “Slide Presentation Evaluation” 
handouts to the students. 
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STEP 2: Create the PowerPoint Presentation 
For the remaining class sessions, the team members should work together to develop their 
presentations. When the teams are done, they should turn in an electronic copy of the 
presentation to you. Evaluate all presentations using the “Slide Presentation Evaluation” 
handout. 

ENRICHMENT ACTIVITY: Create a PowerPoint Presentation 
About Yourself 
Each student can create a 10-slide PowerPoint presentation about him- or herself, including 
photographs, graphics, sounds (if the student is adventurous), and text. 
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Basic PowerPoint Skills 
 
Name: _______________________________ Date: _____________ Class: _________ 
 
In Microsoft PowerPoint, a slide is a page in a presentation that contains text and possibly 
graphics. The table below lists PowerPoint actions you can use to create a presentation, 
brief descriptions of how to access the actions, and the heading of the online Help section 
that provides instructions on how to use the features. 
 

PowerPoint Action How to Get Started 
Create, edit, and save slides File > New 

File > Open 
File > Save 

Use views View > Normal 
View > Slide Sorter 
View > Notes Page 
View > Slide Show 

Use design templates Format > Apply Design Template 
Lay out slides Format > Slide layout 
Add, delete, and reorder slides Insert > New Slide 

Edit > Delete Slide 
View > Slide Sorter 

Add and format text Click a text box or other component and type 
Format > Font 

Add colors and textures Format > Slide Color Scheme 
Format > Background 

Give a presentation View > Slide Show 
Print slides File > Print 
Change all slides with slide master View > Master > Slide Master 
Add pictures, tables, and charts Insert > Picture > Clip Art 

Insert > Picture > From File 
Insert > Chart 
Insert > Table 

Add pictures and documents from other applications Insert > Object, and then select the type of object 
Add animation Slide Show > Animation 

Slide Show > Custom Animation 
Add transitions between slides Slide Show > Slide Transition 
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Presentation Requirements and Tips 
 
Name: _______________________________ Date: ______________ Class: _________ 
 
Presentation Requirements 
One or two team members will present a slide show on the Venture Project, which will 
consist of 10 to 15 slides. Each slide will include a few short sentences or phrases that 
summarize an important point about the Project. The slides can also include graphical 
elements, including portions of the site pages, as long as the slide’s text remains clearly 
readable at all times. 
 
The slides should present the most important points of the Project: 

• What was the Project? 
• Who was the client? 
• What were the client’s needs? 
• How did you meet those needs? 
• What was the greatest challenge you faced in the Project, and how did you meet that 

challenge? 
• What was the estimated value of the Project? 

 
Use the following tips and the “Slide Presentation Evaluation” handout to guide you while 
you create your presentation. Your teacher and classmates will use this handout to assess 
your presentation during the next lesson. 
 
Appearance of the Slides 
Ensure that graphical content does not make it difficult to read the text. Make sure there’s 
plenty of contrast between the text and its background, and that any texture behind the 
text is not distracting. In the case of presentations, simpler is better. 
 
Content, Style, and Delivery of the Text 

• Make sure the slides are easy to read, with at most six phrases or sentences per 
slide. In writing each slide’s bulleted list, make them either all sentences or all 
phrases. That style will make it easier for the audience to understand the content of 
the slide. If you use phrases, don’t use punctuation at the end. If you use sentences, 
use ending punctuation. 

• Carefully plan what the presenter/s will say to augment (enhance) the information 
on the slide. Plan the verbal transition from one slide to the next, whether it’s on the 
same topic or not. All team members should work on the narrative (the supporting 
text).  

• Consider using the PowerPoint Notes feature to write down the narrative.  
• To make the speech livelier and more spontaneous, write down the narrative as 

notes rather than word-for-word. This allows the presenter to speak rather than read 
a script. If there are two presenters, make sure they smoothly coordinate their 
speaking responsibilities. 
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Slide Presentation Evaluation 
 
Team Name:  _____________________________  Date:  ________  Class:  _________ 
 
Use this handout to evaluate the Venture Project slide presentation. Check the box that best 
describes the presentation in each category (row). Points for evaluations are at the top of 
each column. Add the evaluation points for all categories, and write the number in the Total 
Points area at the bottom of the handout. 
 

 
1 Point 2 Points 3 Points 4 Points 

Quality of Writing  Learning to use 
grammar, spelling, 
and punctuation. 

 Uses appropriate 
grammar, spelling, 
and punctuation.  

 Has mastered the 
basic rules of 
writing.  

 Writing is flawless 
and of professional 
quality.  

Clarity of 
Information 

 Main message is 
unclear; information 
is disorganized. 

 Main message is 
somewhat clear, 
and somewhat 
organized. 

 Main message is 
clear and organized. 

 Main message is 
very clear and easy 
to understand.  

Accuracy of 
Information 

 Data is missing or 
inaccurate. 

 Data is accurate, 
with some lapses. 

  Data is accurate.   Data is very 
accurate.  

Audience  Information is not 
appropriate to 
audience. 

 Information is 
somewhat 
audience-
appropriate. 

 Information is 
appropriate to 
audience. 

 Information is 
highly appropriate 
to audience. 

Layout and 
Design 

 Text is not easy 
to read. Colors 
and/or backgrounds 
are distracting. 

 Text is somewhat 
easy to read. Colors 
and/or backgrounds 
contribute 
somewhat to 
message. 

 Makes effective 
use of text, layout, 
colors, and/or 
backgrounds. 

  Shows high 
degree of 
understanding of 
visual design 
elements. 

Graphics  There are no 
images, or the 
images are of low 
quality or 
inappropriate. 

 Some images are 
of low quality, 
inappropriate, or do 
not contribute to 
presentation. 

 Images are 
appropriate and 
contribute to the 
presentation. 

 Images are used 
creatively and 
convey a common 
theme throughout 
the presentation. 

 
Total Points _________ 
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Lesson 3 

Give Venture Presentations 
 

Unit objective 

Present the Venture Project: 
• Estimate the value of the Venture Project 
• Develop basic PowerPoint skills 
• Create a PowerPoint presentation 
• Prepare, rehearse, and give an oral presentation with slides 
• Evaluate a presentation 

Academic 
objectives 

• Identify the components of an effective presentation 
• Plan, rehearse, and give an oral presentation 

IT objectives • None  

Business 
objectives 

• Give constructive feedback 
• Assess your presentation and performance 

Suggested class 
sessions 

4  

Materials None 

Handouts 

Criteria for Evaluating Presentations 
Guidelines for Giving Presentations 
Giving and Getting Constructive Feedback 
Presentation Feedback Form 
Instructor Evaluation Form 
Team Self-Evaluation Form 

Web links None 

Types of activities 
Brainstorming 
Presentation 
Writing 

Homework None 

Enrichment 
activity 

Present the Venture Projects to Other Groups 

INTRODUCTION 
In this lesson, the students work together in teams to plan and present their Venture 
Projects to the class. The ability to orally present information is a key skill in the business 
world. Similarly, the ability to provide constructive feedback to a presenter and receive 
feedback from an audience is essential to succeeding in personal and professional 
relationships.  
 
Specifically, students will: 

• Give a presentation to the class 
• Accept feedback from classmates 
• Give feedback to other presenters 

 
Before beginning this lesson, students should: 

• Understand how to use PowerPoint to create a presentation (Unit 6, Lesson 1) 
• Have completed their Venture Project presentation (Unit 6, Lesson 2)  
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WORDS OF THE DAY 
• Constructive feedback. When reviewing someone else’s work, it is best to put 

yourself in the other person’s shoes and consider her feelings before you comment. 
Comment on the positive aspects of the work first and foremost; be descriptive 
rather than judgmental; suggest alternatives when possible.   

• Criteria. Actions are usually based upon certain standards that are set for that 
particular action. You drive a car based on criteria that are set to keep everyone on 
the road safe. You develop Web pages based on standard Web development 
techniques. 

• Positive feedback. Positive feedback is similar to constructive feedback. This type 
of feedback allows the presenter to feel good about his work, even if it is not perfect. 
Positive feedback focuses on the positive aspects of the work, rather than the 
negative.   

• Self-evaluation. Introspection is a necessary activity. People can look at 
themselves, their actions, and their accomplishments, and decide how close they 
came to accomplishing their goals. Self-evaluation allows for personal growth.  

TEACHER PREP 
Arrange to duplicate any materials your students plan to distribute during their 
presentations. It would be best for each team to distribute copies of their presentations to 
their classmates so they can follow along during the presentations. This simulates the 
normal activity in a business meeting. Every participant is given a copy of the presentation 
so they can take notes directly on the slides during the discussion.  

Lesson Glossary 
• Constructive feedback. Practical and useful comments on a piece of work that 

allow the author to improve it.  
• Criteria. A standard upon which an item is judged, based, or built.  
• Negative feedback. Comments that focus on the negative aspects of a piece of 

work. This type of feedback can be detrimental to a team atmosphere. 
• Positive feedback. Similar to constructive feedback, it focuses on the positive 

aspects of a piece of work.   
• Self-evaluation. Introspection. 

STEP 1: Brainstorm the Components of an Effective 
Presentation  
Ask the students to think about presentations they have attended either in or out of school. 
In particular, ask them to consider what made them pay attention to, and learn from, some 
presentations more than others.  
 
After a minute or two, ask the students to share their thoughts in a brainstorming session. 
While they’re offering ideas, record them on the blackboard in two columns, one for “pluses” 
(positive factors) and one for “minuses” (negative factors). 
 
Distribute the “Criteria for Evaluating Presentations” and “Guidelines for Giving 
Presentations” handouts. Using the brainstormed list and the handout, review the factors 
that contribute to an effective presentation. Introduce the “Presentation Feedback Form” the 
students will use to give each other feedback on their presentations. 
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STEP 2: Plan the Presentation 
Ask the students to meet in their Venture Project teams to plan their presentations. They 
should refer to the “Criteria for Evaluating Presentations” handout for guidance. Including 
their slide show, the students should plan a 15- to 20-minute presentation. 
 
The students should schedule time with you to duplicate any materials they plan to 
distribute, and decide who will present the various aspects of their Project. They should also 
rehearse their presentation at least once. 

STEP 3: Discuss Constructive Feedback 
As a class, review the guidelines on the “Giving and Getting Constructive Feedback” 
handout. Discuss the importance of sharing positive and negative comments. Remind the 
students how it feels when someone has only bad things to say about something you’ve 
done. 

STEP 4: Give Constructive Feedback 
For the rest of the class sessions, the Venture Project teams will present their Projects to 
the rest of the class. During the presentations, you should complete the “Instructor 
Evaluation Form” handout. 
 
After each presentation, ask the rest of the students in the class to complete a copy of the 
“Presentation Feedback Form,” keeping in mind the guidelines for giving and getting 
constructive feedback. Collect the completed feedback forms and distribute new ones before 
each presentation. 
 
After each class session, make copies of the completed feedback forms and give them to the 
team whose work was critiqued. 

STEP 5: Complete a Self-Evaluation 
Ask each team to complete a self-evaluation of its presentation using the “Team Self-
Evaluation” handout. 

ENRICHMENT ACTIVITY: Present the Venture Projects to Other 
Groups 
Arrange for the students to give their presentations to other groups who might be 
interested, including: 

• Other classes in school 
• Other YTE classes in school 
• Parents 
• Teachers in various academic departments 
• The school or district’s IT staff 
• The school committee 
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Criteria for Evaluating Presentations 
Source: http://academic.engr.arizona.edu/HWR/hwr203Fall2002/IndexImages/criteriaEvalPresent.pdf  
 
Content  • Is solid information presented?  

• Is it the correct amount of information?  

• Is the information appropriate to the assignment?  

• Are topics and examples related to everyday interests of the audience?  

Organization • Is there a clear beginning, middle, and end?  

• Is the opening strong, with a clear statement of the topic and overview of the 
presentation contents?  

• Are the main claims well supported?  

• Are forward and backward anchors used? 

• Is the ending strong and conclusive? 

Delivery  • Does the speaker stand straight and not fidget?  

• Does the speaker make eye contact with the audience?  

• Does the speaker appear prepared?  

• Does the speaker seem enthusiastic about the topic?  

• Does the speaker appear competent and confident?  

• Does the speaker speak clearly and loudly? 

Visuals  • Are visuals used effectively?  

• Can visuals be seen easily from everywhere in the room?  

• Do visuals use key phrases instead of sentences?  

• Do the visuals help the audience follow the presentation?  

• Does the speaker discuss the visuals without simply reading them to the audience?  

• Does the speaker maintain contact with the audience while discussing visuals?  

Questions  • Does the speaker announce a policy about questions at the beginning?  

• Does the speaker initiate and terminate the question-and-answer period?  

• Does the speaker repeat and clarify all inaudible or confusing questions?  

• Does the speaker listen to the whole question before responding?  

• Does the speaker respond to the whole group rather than just the questioner? 

• Does the speaker use the question period effectively to further the purpose of the 
presentation?  

• Are questions numerous and interesting?  
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Guidelines for Giving Presentations 
 
Source: http://www.prospects.ac.uk/cms/ShowPage/Home_page/Applications_and_interviews/Interviews/ 
Assessment_centres/Giving_presentations/p!efaLa 
 

• Plan your presentation carefully along A-B-A lines:  
o Tell them what you’re going to tell them 
o Tell them what you have to say 
o Tell them what you’ve told them  

• Limit your points to no more than six main messages.  
• Pitch the level of your talk at your audience and keep it clear—don’t give too much 

detail.  
• Support your ideas and themes with anecdotes, examples, statistics, and facts. Don’t 

be afraid to use humor appropriately.  
• Aim for a conversational delivery and talk from notes. Do not memorize or read from 

a full script. You may find it helpful to fold or cut notes to hand size (5 x 4-inch index 
cards work well).  

• Make eye contact with all members of the group at least once during the 
presentation.  

• Talk to the group, not at it.  
• Keep to time. Bear in mind that your nerves can cause you to speed up or slow 

down.  
• Speak clearly, don’t mumble, and talk louder than you think necessary.  
• Be aware of your body language and don’t fidget while you talk.  
• Ask someone to listen to your presentation beforehand so you know if you have any 

annoying habits, or if you repeat words like “okay,” “er,” or “you see” too often.  
• If you are using an overhead projector, avoid walking in front of the screen or 

reading the transparencies to your audience. Refer to them by all means, but allow 
them to illustrate/back up/summarize what you are saying—images are generally 
more effective than words.  

• Handle any questions using the mnemonic, TRACT: 
o Thank the questioner 
o Rephrase the question for the rest of the audience 
o Answer the question to the group 
o Check with the questioner to ensure he is satisfied with your answer 
o Thank the questioner again 
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Giving and Getting Constructive Feedback 
 
Adapted from: http://www.wellclosesquare.co.uk/training/mentor/feedback.htm  
 
Guidelines for Giving Constructive Feedback 

• Focus on the positive; give positive feedback first and last 
• Be descriptive, not judgmental 
• Talk about specifics and give an example when possible 
• Suggest alternatives where appropriate 
• Give negative feedback only about things that can be changed 
• Give feedback only when asked to do so, or when your offer of feedback has been 

accepted 
 
Guidelines for Receiving Feedback 

• Listen to feedback 
• Assume that feedback is constructive 
• Use and consider only those elements that are constructive, and consider them 

carefully 
• Pause and think before responding 
• Ask for clarification or examples if statements are unclear or unsupported 
• Accept negative feedback for consideration, rather than dismissing it 
• Ask for suggestions on ways you might modify or change something 
• Respect and thank the person giving the feedback 
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Presentation Feedback Form 
 
Team Name:  ______________________________ Date:  ________  Class:  _________ 
 
Student Evaluator:   ___________________________ 
 
Adapted from: http://academic.engr.arizona.edu/HWR/hwr203Fall2002/IndexImages/criteriaEvalPresent.pdf and 
http://people.english.ohio-state.edu/bailey.389/Teaching/Eng36707/eval_presents.htm  
 
Rate the presentation in each of the five areas by placing an “X” in the appropriate box. 
Then, answer the two questions at the bottom. 
 

Category Excellent Very Good Good Fair Poor 
 
Content 
 

 
 
 

    

 
Organization 
 

 
 
 

    

 
Delivery 
 

 
 
 

    

 
Visuals 
 

 
 
 

    

 
Questions 
 

 
 
 

    

 
From this presentation, I learned: 
 
 
 
 
 
 
To improve the presentation, you might: 
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Instructor Evaluation Form 
 
Team Name:  _____________________________  Date:  ________  Class:  _________ 
 
Use this handout to evaluate the Venture Project slide presentation. Check the box that best describes the presentation in each 
category (row). Points for evaluations are at the top of each column. Add the evaluation points for all categories, and write the 
number in the Total Points blank at the bottom of the handout. 
 

Category 1 Point 2 Points 3 Points 4 Points Comments 

Quality of Writing  Learning to use 
grammar, spelling, and 
punctuation. 

 Uses appropriate 
grammar, spelling, and 
punctuation.  

 Has mastered the 
basic rules of writing.  

 Writing is flawless and 
of professional quality.  

 
 
 
 

Clarity of Information  Main message is 
unclear; information is 
disorganized. 

 Main message is 
somewhat clear, and 
somewhat organized. 

 Main message is clear 
and organized. 

 Main message is very 
clear and easy to 
understand.  

 
 
 
 

Accuracy of 
Information 

 Data is missing or 
inaccurate. 

 Data is accurate, with 
some lapses. 

  Data is accurate.   Data is very accurate.   
 
 
 

Audience  Information is not 
appropriate to audience. 

 Information is 
somewhat audience-
appropriate. 

 Information is 
appropriate to audience. 

 Information is highly 
appropriate to audience. 

 
 
 
 

Layout and Design  Text is not easy to 
read. Colors and/or 
backgrounds are 
distracting. 

 Text is somewhat easy 
to read. Colors and/or 
backgrounds contribute 
somewhat to message. 

 Makes effective use of 
text, layout, colors, 
and/or backgrounds. 

  Shows high degree of 
understanding of visual 
design elements. 

 

Graphics  There are no images, 
or the images are of low 
quality or inappropriate. 

 Some images are of 
low quality, 
inappropriate or do not 
contribute to 
presentation. 

 Images are 
appropriate and 
contribute to the 
presentation. 

 Images are used 
creatively and convey a 
common theme 
throughout the 
presentation. 

 

Vocal   Too quiet, too fast, 
and/or mumbles. 
Difficult to hear and 
understand. 

 Uses appropriate 
volume, tempo, and 
enunciation, with some 
lapses. 

 Speaks clearly. Easy 
to understand and 
follow. 

 Has exceptionally 
clear vocal intonation, 
tempo, and volume.  
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1 Point 2 Points 3 Points 4 Points Comments 

Physical  Very nervous. Avoids 
eye contact. Makes 
distracting gestures or 
movements 

  Maintains good 
composure, eye contact 
in front of a group, with 
some lapses. 

  Is confident and 
poised. Few distractions. 
Connects well with 
audience. 

 Is a very poised and 
engaging speaker who 
clearly enjoys speaking. 
No distractions. 

 

Preparation  Doesn’t know the 
material. No evidence of 
practice. 

 Knows the material 
with some lapses. 
Evidence of some 
practice. 

 Knows the material 
well. Strong evidence of 
practice. 

 Has fully internalized 
the material. Strong 
evidence of practice and 
polish. 

 

 
Total Points _________ 
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Team Self-Evaluation 
 
Team Name:  ______________________________ Date:  ________  Class:  _________ 
 
Source: http://academic.engr.arizona.edu/HWR/hwr203Fall2002/IndexImages/criteriaEvalPresent.pdf  
 
Reflect on your team presentation. Comment on how well it met the criteria in each 
category. 
 

Category Criteria Comments 

Content  • Was solid information presented?  

• Was it the correct amount of information?  

• Was the information appropriate to the assignment?  

• Were topics and examples related to everyday interests of the 
audience?  

 

Organization • Was there a clear beginning, middle, and end?  

• Was the opening strong, with a clear statement of the topic and 
overview of the presentation contents?  

• Were the main claims well supported?  

• Were forward and backward anchors used? 

• Was the ending strong and conclusive? 

 

Delivery  • Did the speaker stand straight and not fidget?  

• Did the speaker make eye contact with the audience?  

• Did the speaker appear prepared?  

• Did the speaker seem enthusiastic about the topic?  

• Did the speaker seem competent and confident?  

• Did the speaker speak clearly and loudly? 

 

Visuals  • Were visuals used effectively?  

• Could visuals be seen easily from everywhere in the room?  

• Did visuals use key phrases instead of sentences?  

• Did the visuals help the audience follow the presentation?  

• Did the speaker discuss the visuals without simply reading them 
to the audience?  

• Did the speaker maintain contact with the audience while 
discussing visuals?  

 

Questions  • Did the speaker announce a policy about questions at the 
beginning?  

• Did the speaker initiate and terminate the question-and-answer 
period?  

• Did the speaker repeat and clarify all inaudible or confusing 
questions?  

• Did the speaker listen to the whole question before responding?  

• Did the speaker respond to the whole group rather than just the 
questioner? 

• Did the speaker use the question period effectively to further 
the purpose of the presentation?  

• Were questions plentiful and interesting?  
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Lesson 4 

Unit Assessments 
 

Unit objective 

Present the Venture Project: 
• Estimate the value of the Venture Project 
• Develop basic PowerPoint skills 
• Create a PowerPoint presentation 
• Prepare, rehearse, and give an oral presentation with slides 
• Evaluate a presentation 

Academic 
objectives 

• Show understanding of the academic content of this unit 

IT objectives • None  

Business 
objectives 

• Show understanding of the business content of this unit 

Suggested class 
sessions 

2  

Materials None 

Handouts PowerPoint Presentation Storyboard 

Web links None 

Types of activities 
Presentation 
Writing 

Homework None 

Enrichment 
activity 

None 

Skills Assessment 
Imagine you are going to give a slide presentation about your community to a friend who is 
visiting from a different state.  
 
Using the copies of the “PowerPoint Presentation Storyboard” handout, create a six-slide 
presentation about your neighborhood, town, or city. Sketch and/or describe any images 
you want to include. In the Notes area, indicate the information you plan to present verbally 
as you show each slide. 
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PowerPoint Presentation Storyboard 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
       Slide # ____  
       Notes area: 
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Vocabulary Assessment 
 
Name: _____________________________ Date: ______________ Class: _________  
 
 
Write examples for each of the defined vocabulary words below: 
 
Market value. The value of a product or service on the open market; the salary an 
employee can expect depending on his/her qualifications  
 
Example: 
 
 
 
 
Supply and demand. When supply is great and demand is low, prices are low; when 
supply is low and demand is great, prices are high. 
 
Example:  
 
 
 
 
Layout. The arrangement, placement, or design of elements on a page or document.  
 
Example: 
 
 
 
 
Self-evaluation. Introspection. 
 
Example: 
 
 
 
 
Template. A pattern that serves as a guide. 
 
Example: 
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Knowledge Assessment 
 
Name:  ____________________  Date:  __________________  Class:  ___________ 
 
SECTION A 
 
Answer questions 1 – 4 in the spaces provided. 
 
1. When a person giving a presentation is asked a question, what five steps should 

he/she follow when providing the answer? 
 
 
 
 
 
 
 
 
 
 
 
 
2. List the guidelines for giving constructive feedback on a presentation. 
 
 
 
 
 
 
 
 
 
 
 
 
3. List the guidelines for receiving feedback on a presentation. 
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4. List the five criteria that should be used to evaluate a presentation. For each 
criterion, write three questions that should be considered when evaluating the 
effectiveness of the presentation.    

 
Criterion:  
 
Questions:   
1.  
 
2.  
 
3.  
 
Criterion:  
 
Questions:   
1.  
 
2.  
 
3.  
 
Criterion:  
 
Questions:  
1.  
 
2.  
 
3.  
 
Criterion:  
 
Questions:   
1.  
 
2.  
 
3. 
  
Criterion:  
 
Questions:  
1.  
 
2.  
 
3. 
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SECTION B 
 
Circle the correct answer. 
 
1. Which of the following should be avoided when planning a presentation? 
 A.  Allowing all team members to contribute information 
 B.  Writing word-for-word notes for the presentation  
 C.  Incorporating bulleted lists in slide presentations 
 D.  Making visual presentations simple and focused 
 
 
2. A ___________________ is a preset area on a PowerPoint slide where text or 

graphics can be inserted. 
 A.  placeholder 
 B.  slide master 
 C.  template 
 D.  slide transition 
 
 
3. How many main messages should a presentation include? 
 A.  Only one 
 B.  No more than three 
 C.  No more than six 
 D.  As many as necessary 
 
 
4.  Which salary range best reflects that of a Network Administrator?  
 A.  $30,000 to $50,000 
 B.  $50,000 to $70,000 
 C.  $70,000 to $100,000 
 D.  $100,000 to $150,000 
 
 
5. Which equation should be used to calculate a person’s hourly rate of pay? 
 A.  Hourly Rate = Salary ÷ 50 
 B.  Salary ÷ 40 = Hourly Rate 
 C.  2000 ÷ Salary = Hourly Rate 
 D.  Hourly Rate = Salary ÷ 2000 
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Knowledge Assessment 
 
Name:  ANSWER KEY__________  Date:  __________________  Class:  ___________ 
 
SECTION A 
 
Answer questions 1 – 4 in the spaces provided. 
 
1. When a person giving a presentation is asked a question, what five steps should 

he/she follow when providing the answer? 
 

• Thank the person who asked the question 
• Rephrase or restate the question for the rest of the audience 
• Answer the question to the entire group 
• Check with the person who asked the question to ensure he/she is satisfied with 

the answer 
• Thank the person who asked the question again 

 
2. List the guidelines for giving constructive feedback on a presentation. 
 

• Focus on the positive; give positive feedback first and last 
• Be descriptive, not judgmental 
• Talk about specifics and give an example when possible 
• Suggest alternatives where appropriate 
• Give negative feedback only about things that can be changed 
• Give feedback only when asked to do so, or when your offer of feedback has 

been accepted 
 
3. List the guidelines for receiving feedback on a presentation. 
 

• Listen to feedback 
• Assume that feedback is constructive 
• Use and consider only those elements that are constructive, and consider 

them carefully 
• Pause and think before responding 
• Ask for clarification or examples if statements are unclear or unsupported 
• Accept negative feedback for consideration, rather than dismissing it 
• Ask for suggestions of ways you might modify or change something 
• Respect and thank the person giving the feedback 
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4. List the five criteria that should be used to evaluate a presentation. For each 

criterion, write three questions that should be considered when evaluating the 
effectiveness of the presentation.    

 
Criterion: Content 
 
Questions: (The questions listed below may vary.)  
1. Is an adequate amount of information provided? 
 
2. Is the information presented appropriate to the assignment? 
 
3. Are topics and examples related to the everyday interests of the audience? 
Criterion: Organization 
 
Questions: (The questions listed below may vary.)  
1. Is there a clear beginning, middle, and end to the presentation? 
 
2. Is the opening strong, with a clear statement of the topic and overview of the 
    presentation’s content? 
 
3. Are the main claims well supported?  
Criterion: Delivery 
 
Questions: (The questions listed below may vary.) 
1. Does the speaker make eye contact with the audience? 
 
2. Does the speaker seem enthusiastic about the topic? 
 
3. Does the speaker speak clearly and loudly?  
Criterion: Visuals 
 
Questions: (The questions listed below may vary.)  
1. Do visuals help the audience follow the presentation? 
 
2. Does the speaker discuss the visuals without simply reading them to the 
    audience? 
 
3. Do visuals use key phrases instead of sentences?  
Criterion: Questions 
 
Questions: (The questions listed below may vary.)  
1. Did the speaker listen to the whole question before responding? 
 
2. Did the speaker respond to the whole group rather than just the person asking 
    the question? 
 
3. Was the question period used effectively to further the purpose of the  
    presentation? 
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SECTION B 
 
Circle the correct answer. 
 
1. Which of the following should be avoided when planning a presentation? 
 A.  Allowing all team members to contribute information 
 B.  Writing word-for-word notes for the presentation 
 C.  Incorporating bulleted lists in slide presentations 
 D.  Making visual presentations simple and focused 
 
 
2. A ___________________ is a preset area on a PowerPoint slide where text or 

graphics can be inserted. 
 A.  placeholder 
 B.  slide master 
 C.  template 
 D.  slide transition 
 
 
3. How many main messages should a presentation include? 
 A.  Only one 
 B.  No more than three 
 C.  No more than six 
 D.  As many as necessary 
 
 
4.  Which salary range best reflects that of a Network Administrator?  
 A.  $30,000 to $50,000 
 B.  $50,000 to $70,000 
 C.  $70,000 to $100,000 
 D.  $100,000 to $150,000 
 
 
5. Which equation should be used to calculate a person’s hourly rate of pay? 
 A.  Hourly Rate = Salary ÷ 50 
 B.  Salary ÷ 40 = Hourly Rate 
 C.  2000 ÷ Salary = Hourly Rate 
 D.  Hourly Rate = Salary ÷ 2000 

 


